Installation FAIL

  • Govido,
    Thanks, but i dont think we solved the problem.
    I switched to the original config.xml as you suggested (formely called config.local.xml).
    But it doesn't connect, it connects only I use your config.xml (now named oldconfig.xml), which unfortunately connect to external web services and db.
    You have my ftp credential and see it as I do,
    Thanks though

  • Hello, please PM your FTP access again, we don't keep data saved to avoid any misunderstanding.

  • Ok I sent them again,

  • Working on it … almost done. You'll receive the latest 0.9.x version that will connect automatically, even without config. I did test yesterday night and worked fine, today it does not connect any more. This is due to a asleep-made change, I have to locate and revert.

  • Please check if it works (connects) now. If yes, will send you the web-service package.

  • @'Govido':

    Please check if it works (connects) now. If yes, will send you the web-service package.

    Not connected. …..

  • If ra*** is your domain, it is connected. Please, always clear the browser cache before testing.

  • @'Govido':

    If ra*** is your domain, it is connected. Please, always clear the browser cache before testing.

    ok it is connected, sorry about that, I forgot to clear the cache.
    I've really appreciated your help.
    I have two questions:
    1 what the problem was and how you solved it
    2 there are many users on the website now which are not supposed to be. Indeed, we didn't advertise the website. This is very weird, is the script is connecting to another network ?

    Update, I checked and probably understood. I am sorry but i think nothing was solved, the script doesn't use nor my config.xml neither my config.php.
    I disabled them and the script still works, meaning that it doesn't use them.
    In addition the script does not use my own database.
    It is just connect to some other script and use the db, network (user through another domain)

  • Hello bassfly,

    For others, who are reading this post, here is the video chat script / free download (SVC-SR 0.9 at the moment), ready to download (and for testing).

    This script will attempt connection to your local web service (your database) and if this connection fails for any reason, it will continue to search and connect to any available SVC web service. This is useful when someone is having problems with locating a connection issue.

    • if the software starts but connects to remote web service, it means, your config.xml is 1. misconfigured 2. missing 3. not accessible (check server settings/file-access rights with your admin)
    • if the software starts and does not connect, it means, your config.xml was found and loaded but your config.php is misconfigured and SVC cannot connect to your local database.

    *all versions prior to 0.9 will fail connecting or will produce connection errors, due to a different database structure

    I will upload the new database and web-service to your server. This script MUST connect. If not, your config.xml is not accessible (reason described above).

  • @'Govido':

    Yes, the problem is caused by crossdomain.xml. Use this file (file content below) instead of what you have on your domain, in the root folder. If you are using a sub-domain, copy the crossdomain.xml to the respective folder. Please be aware, this file will allow access to your web-service from ANY domain. For example, I can connect to your web-service remotely and use your database. To fix that, edit crossdomain.xml.
    More info:

     <cross-domain-policy><allow-access-from domain="*"></allow-access-from></cross-domain-policy> 

    Govido, after two weeks we are going back with the initial problem of the config.xml and crossdomain ?
    I do not understand. I bought and installed RVC on the same domain without any problem of file permission.
    Any clue? I need to use my own database and the videochat should be open only to people that obviously go to my website.
    I need my database because I will need to have user registration.
    IS the SVC version you installed is editable, see Ronaldo last post?

  • Bassfly, the latest version is up and running on your server, will update this post in about 20 minutes, regarding the local connection.
    Ronaldo1981, the source was released about a week ago and should be available for download any moment, please follow @govido

  • Bassfly, tried everything, I could think of. Now, with the new version it is even possible to test if the SVC has access and reading your XML; it does. After you change the web service from "remote" to "local", your software fails to connect. The config.php is ok since the installer runs without errors. There is one last thing you can try:

    • DROP the database (delete all tables, everything) and DO NOT use the installer. Instead, import this SQL (unzip first than import to your DB via phpMyAdmin). This is almost the exact copy of the relevant tables of Govido's database and it has to work with all SVC 0.9 and 1.0 versions.
      *if this will not solve your problem, means, the software does not have access to your web-service files, it does read the path from XML but cannot access the local web-service. The software on the other hand runs fine with ANY other remote service, meaning, your local file access is banned (this is just a thought, the SQL should solve the issue).

  • Drop the tables, and run the sql.
    The software is still connecting on remote services, I mean, it's even difficult to test if the software is working locally because it automatically connect to remote webservices.

  • Try to reload your browser after clearing the cache. The SVC is set to use local web service.

  • It says "not connected", I guess you can even see if you go to my website…

  • Yes, if you loaded the above-mentioned SQL structure to your database and the script does not connect means, the Flash application does not have access to your local web service (the php files). This is not a software issue but a server-security setting. Please contact your server admin or relocate the web service to any server with PHP/MySQL support.

  • Well, this can be an issue, since my hosting is with hostgator, which is one of the most popular hosting and you may have the same problem with many of your customers.
    Sometime ago you said you solved the problem with crossdomain.xml?
    Which file is trying to access which file?
    E.g., videochat.swf -> config.php

  • VideoChat.swf should have read access to configuration.php and registration.php

  • Hi Govido, thanks for your help.
    I solved the problem and I hope that this post can help people.
    I contacted the support for hostgator and the script was striking their extensive mod_security rules.
    They whitelisted the mod_security rules and the script now works.
    On a side note, the problem is that hostgator doesn't allow videochat for shared accounts. That means you need to move to a VPS or dedicated server.
    I think would be helpful to know if bluehost allows videochat on shared servers….cause the price for a VPS is very expensive

  • Bassfly, thank you for the notice. This will help others, having the same issue. Do you thing it is possible to ask what exactly did they change in your local php.ini or .htaccess file to override the default mod_security setting? I mean what was the parameter that needed to be changed?
    You don't need to switch to other server in such case, just move the web-service on any PHP/MySQL -ready server. An Amazon S3 - Simple Storage Service should do it and may be the best option.

Log in to reply