Installation FAIL



  • @'Govido':

    No, if you still have the same FTP access, you created for me, just leave config.php as it is (configured to access your db) and I'll take a look.

    ok I renamed the old config.php "oldconfig" and created a new one "config.php"
    both of them are correct and succesfully connect to two different db (i did for testing).



  • It does not work. Anyway, go ahead with your project, edit the software, make your changes to your site. With SVC you don't need local web service, it can be anywhere on the web. I created a special xml file that connects to a remote server, use this connection for a few days until I give it a try again. This web service is also ready for upcoming 0.9 and 1.0 versions -if you plan to download them as they become available- and it should not affect your project in any way. After we figure out the issue, you just rename config.local.xml to config.xml and switch back to local database.

    The strangest thing: if I move this web service to any other domain ex. videosoftware.pro, it does not work with your site/server. I also tried with and IP-address and no luck. Well this is strange enough to give up and have a sleep before trying it again.



  • Gotcha, thank you.
    It is very weird indeed. Besides pointing to registration.php on the new url "xxcio.co", is the config.xml using an external db or my own db?

    Also, how can i activate the facebook login? For what I read on your website, svc is modular, but it is not explained
    1 which modules include
    2 how activate them
    Thanks

    Forgot to say something helpuful to understand the problem with SVC, on the same url I installed RVC and it worked perfectly, see home/rvc.



  • Your website is using a remote web service, with remote database. The facebook login is explained somewhere on this forum by Video Chat, you will need some php/javascript knowledge in order to use it. This feature was developed for the facebook video call app and that source code is not released. A working sample, including the source code may arrive with version 1.0 but my guess is that will never be included. Much rather a comprehensive description with downloadable (working) sample on this forum.

    Meanwhile it is possible to copy the whole technology by viewing the source code of the demo sites, both HTML and .js sources. The php code, you need can be found here: http://www.videosoftware.pro/forum/THREAD-SVC-questions?pid=4948#pid4948



  • mmm so it;s better to avoid populating my own db with registered users until you find a solution ?

    Thanks for the link, I have just two questions

    1. which modules are native in SVC and can be activated? (e.g., facebook login, filtering, ???)
    2. Do anybody in videosoftware is willing to do few modifications on SVC or RVC under payment?



  • You can use this DB freely. As soon as you switch to your own DB, all users will switch as soon as a new status is requested/reported, this is set to 2 seconds on the web service you're using. Before switching I can lower the config refresh time from 60 min to 1 second.

    1. Facebook login
    2. More than likely not. You may try finding someone here Flex and Flash Builder projects and/or jobs



  • Hi Govido,
    Did you find the solution for the bug in the software?
    I will need to use my own server and db for customization and testing pretty soon.
    Thanks in advance
    F



  • Hello,
    Yes, the problem is caused by crossdomain.xml. Use this file (file content below) instead of what you have on your domain, in the root folder. If you are using a sub-domain, copy the crossdomain.xml to the respective folder. Please be aware, this file will allow access to your web-service from ANY domain. For example, I can connect to your web-service remotely and use your database. To fix that, edit crossdomain.xml.
    More info:
    http://kb2.adobe.com/cps/142/tn_14213.html
    http://www.adobe.com/devnet/articles/crossdomain_policy_file_spec.html

    
     <cross-domain-policy><allow-access-from domain="*"></allow-access-from></cross-domain-policy> 
    
    


  • **<allow-access-from domain="*.domain.com"></allow-access-from>**will fix the above-mentioned issue.



  • Govido,
    Thanks, but i dont think we solved the problem.
    I switched to the original config.xml as you suggested (formely called config.local.xml).
    But it doesn't connect, it connects only I use your config.xml (now named oldconfig.xml), which unfortunately connect to external web services and db.
    You have my ftp credential and see it as I do,
    Thanks though
    F



  • Hello, please PM your FTP access again, we don't keep data saved to avoid any misunderstanding.



  • Ok I sent them again,
    Thanks
    F



  • Working on it … almost done. You'll receive the latest 0.9.x version that will connect automatically, even without config. I did test yesterday night and worked fine, today it does not connect any more. This is due to a asleep-made change, I have to locate and revert.



  • Please check if it works (connects) now. If yes, will send you the web-service package.



  • @'Govido':

    Please check if it works (connects) now. If yes, will send you the web-service package.

    Not connected. …..



  • If ra***vu.com is your domain, it is connected. Please, always clear the browser cache before testing.



  • @'Govido':

    If ra***vu.com is your domain, it is connected. Please, always clear the browser cache before testing.

    ok it is connected, sorry about that, I forgot to clear the cache.
    I've really appreciated your help.
    I have two questions:
    1 what the problem was and how you solved it
    2 there are many users on the website now which are not supposed to be. Indeed, we didn't advertise the website. This is very weird, is the script is connecting to another network ?

    Update, I checked and probably understood. I am sorry but i think nothing was solved, the script doesn't use nor my config.xml neither my config.php.
    I disabled them and the script still works, meaning that it doesn't use them.
    In addition the script does not use my own database.
    It is just connect to some other script and use the db, network (user through another domain)
    ????????????



  • Hello bassfly,

    For others, who are reading this post, here is the video chat script / free download (SVC-SR 0.9 at the moment), ready to download (and for testing).

    This script will attempt connection to your local web service (your database) and if this connection fails for any reason, it will continue to search and connect to any available SVC web service. This is useful when someone is having problems with locating a connection issue.

    • if the software starts but connects to remote web service, it means, your config.xml is 1. misconfigured 2. missing 3. not accessible (check server settings/file-access rights with your admin)
    • if the software starts and does not connect, it means, your config.xml was found and loaded but your config.php is misconfigured and SVC cannot connect to your local database.

    *all versions prior to 0.9 will fail connecting or will produce connection errors, due to a different database structure


    I will upload the new database and web-service to your server. This script MUST connect. If not, your config.xml is not accessible (reason described above).



  • @'Govido':

    Hello,
    Yes, the problem is caused by crossdomain.xml. Use this file (file content below) instead of what you have on your domain, in the root folder. If you are using a sub-domain, copy the crossdomain.xml to the respective folder. Please be aware, this file will allow access to your web-service from ANY domain. For example, I can connect to your web-service remotely and use your database. To fix that, edit crossdomain.xml.
    More info:
    http://kb2.adobe.com/cps/142/tn_14213.html
    http://www.adobe.com/devnet/articles/crossdomain_policy_file_spec.html

    
     <cross-domain-policy><allow-access-from domain="*"></allow-access-from></cross-domain-policy> 
    
    

    Govido, after two weeks we are going back with the initial problem of the config.xml and crossdomain ?
    I do not understand. I bought and installed RVC on the same domain without any problem of file permission.
    Any clue? I need to use my own database and the videochat should be open only to people that obviously go to my website.
    I need my database because I will need to have user registration.
    IS the SVC version you installed is editable, see Ronaldo last post?
    Thanks
    F



  • Bassfly, the latest version is up and running on your server, will update this post in about 20 minutes, regarding the local connection.
    Ronaldo1981, the source was released about a week ago and should be available for download any moment, please follow @govido


Log in to reply