Compilation with Flex 4 SDK ?

  • Hi,

    I can't run Flash builder on my platform, so I tried to compile jabbercam with mxmlc compiler (Flex 4 SDK).
    I have no knowledge in flash programming but I succeeded in "hello word" compilations.

    Unfortunately, when I try to compile jabbercam, it doesn't work…

    $mxmlc JabberCam.mxml 
    Loading configuration file /opt/flex/frameworks/flex-config.xml
    /home/ed/tmp/5.1.fxp_FILES/src/JabberCam.mxml(-1):  Error: Access of undefined property DEBUGGING.
    /home/ed/tmp/5.1.fxp_FILES/src/JabberCam.mxml(-1):  Error: Access of undefined property RELEASE.

    What's wrong ?
    Thanks in advance.

  • try removing the property (RELEASE) it is just a simple label, not needed

  • Thank you, I tried and it worked but other errors occurred.

    Finally, this seems to work for linux users :

    $ mxmlc  -theme=/opt/flex/frameworks/themes/Halo/halo.swc   -define+=CONFIG::DEBUGGING,false -define+=CONFIG::RELEASE,true  JabberCam.mxml

    Halo.swc's path may varie, depending on Flex SDK installation.

    I also had to change relative paths in jabbercam/comp/StartupAlert.mxml
    ../assets/ => ../../../assets/

    Some warnings remain but it works.

    An excerpt, just for information :

    ..../assets/style.css: Warning: Type 'Application' in CSS selector 'Label' must be qualified with a namespace. 
    (Same warning for 'Button', 'Textarea', 'Textinput', 'ScrollBar', 'ComboBox' and 'Label')
    ..../src/ Warning: 'getStyleDeclaration' has been deprecated since 4.0\.  Please use 'IStyleManager2.getStyleDeclaration on a style manager instance'.

Log in to reply