[ R 5.9 ] Some problems changing the app recompile, no text and broken functionality



  • I carefully removed the maps integration
    and removed some of the panels like help since I don't need them.
    I checked the source for errors with flash builder, and everything compiled fine.

    I did a "export release build" to /bin-release, uploaded this .SWF replacing the one on my own site ( using stratus ) and functionality was gone like missing text from buttons and no working webcam anymore.

    I have tried reinstalling the server side ( public document root files ) again and configuring again to no avail, it just won't load my webcam anymore. I have rebooted, made sure no other tabs in the browser with the chat app where open en made sure no apps like FaceTime or Skype where running.

    Some concrete questions:

    1. What is the best way to change parts in the interface and test this?
    2. How to make sure you don't break anything on modifications?

    Basically what I need is a cleaned out version of the app, with some features removed and some slight changes to the UI. Did not knew that was so hard to accomplish, or do i make mistakes?



  • At first sight seems that none of these errors are your fault.

    • the first problem (missing text) is usually caused by a modification in /jabbercam/language/lang_en.ini (or other language) file. Try temporary replacing the language files with the originals. Don't forget to clear your browser's cache before reloading the page.

    • the second (your video is missing) is a known issue: http://www.videosoftware.pro/forum/thread-633.html - I don't know a way to fix it yet but don't worry it affects your computer only. It happens wit me all the time when we test the software and reload the page a lot. Try from a different machine if there is no video than you changed something in the source. I also noticed, if I move the same compiled .swf to a different domain, it works …



  • I placed original zip contents back and everything runs fine now

    except…

    the video always says "waiting for video stream "
    if i try jabber chat.com it works fine but my install it does not
    what could cause this? the task=test runs fine (admin) and stratus api key is added
    It does ask for my cam
    It does show me light of cam
    but nothing visual no cam display



  • Send your link in a PM



  • Ok I tried this:

    1. Complete clean install
    2. Orginal SWF no modifications
    3. Stratus with developer keys

    Test1
    –---------------------------
    Windows machine
    MacOSX machine
    Trying to connect 2 each other.

    I load up the chat on windows, webcam asks for authorization, webcam light is on
    I see nothing at the ME section of the webcam

    I load up the chat on OSX, webcamask for authorization, webcam light is on
    I see nothing at the ME section of the webcam
    I click Next on the windows machine, it finds my OSX logged in user
    See the ME cam = on on the windows machine, the partner cam is invisible
    See the Partner cam = on on the mac machine, the me is invisible on the mac machine

    Totally don't get why this not working,
    I tried the open source version with worked out of the box correctly 2 days ago.
    Jabbercam seems to have some problems or I misconfigured



  • I cannot help without taking a look at the running software.



  • I posted link to PM, thanks!



  • Just checked your site and everything seems fine, the config is OK. At this pont I have no idea what is blocking the outgoing video stream (do you have audio?). Also, test jabbercam.com and the link below to see if you encounter the same issue with RVC or SVC:
    http://apps.facebook.com/video-call/



  • Thanks for the reply
    All other sites work.

    My server was configured to have www. and http:// at 2 separate locations, since sometimes in the code there is a http:// and sometimes http://www. this caused some issues,
    this is resolved now again and the chat runs again. Only I still stuck at the video waiting screen.

    When I look in activity under safari OSX I see it tries to get this link:

    http://maps.googleapis.com/mapsapi/publicapi?file=flashapi&url=http%3A%2F%2Fjorries.nl%2FJabberCam.swf&key=removedsomepartsVlqBAxoRS0ikS4ktBLVxgqeKCnbOAWV907DRTtmQB-fNRvJcypkr9x3Z2c1O0r0A&sensor=false&v=1.20&flc=xt&flcl=a2i20ufvvrvvtvvbo03

    This links gives a 404,
    Is the google public API url changed?
    I cannot seem to find it,
    I guess it hangs on that..
    But that link is hardcoded in the swf so without recompile not easy to change,
    I would suggest making the google stuff optional from the config file its a bit of a pain to remove it from the swf every time.

    Can you confirm that the google api url is changed? I get the 404 strangely,
    no idea why jabber cam.com still runs fine



  • There must be something else if all other sites are running the same software are loading the map. Is your google api key inserted in the config? Was the api generated for your site?



  • @'Flexer':

    There must be something else if all other sites are running the same software are loading the map. Is your google api key inserted in the config? Was the api generated for your site?

    arghh! I forgot to change that! Indeed I run the software on a different site now.
    The google maps error is gone with this,
    however I still *have no video.. waiting for video stream error message *

    I can connect 2 times on my local machine and chat with myself in 2 different browser tabs,
    this works. Video does not work at all with this setup ( wich is logic since cam can only be used 1 time at a time)

    However If I connect with another machine I still see no video. Windows / Mac with cleared caches it does not make any difference
    All machines have Flash version 10.3.183.7 the latest that should be compatible :(

    I Want to try red5 instead of stratus anyway but also have issues with that :S ( see other topic, no response on that one yet ;()
    This package is great but I hope to get it up and running now within a respectable time


    It seems that on a windows machine
    with another user from a windows machine it works :S:S:

    Only In mac I cannot get any video whatsoever,
    Really need to have this cross browser compatible, is there an idea, roadmap to fix it for osx since
    it seems not working there only ( osx is my main system so I mostly only test there )



  • When I connect to with a windows machine and with a mac osx machine and click start

    windows:
    I can see myself under "ME" in the video window (right)
    I cannot see the mac osx partner (left)
    I can see any other user from a windows machine (partner,left)

    osx:
    I can see the partner (left)
    I cannot see myself (right)



  • It seems like a mac- camera/driver/fp issue but I saw the same with windows 7 laptops as well. This is a hard one, please get back if you figure out something.



  • This is known issue? that is very bad :
    That would make the app unusable for any mac users.

    If you install wowza media server, there is an example app there for a simple video chat,
    that works correctly on OSX also. ( It uses the wowza media server )

    The problem we need to figure out if this is a general osx problem ( always happen on osx ) or it just happens
    on a local machine ( local problem ). Jabbercam also does the same, asks for cam, no cam visible only partner.
    Maybe this is stratus related ( although that would be really stupid on adobe's site )

    Does it work on OSX with red5 Jabbercam?



  • The first feedback, regarding this issue came from a Sony Vaio PC. During the development of RVC, it happened on a PC, a MacBook Pro and a MacBook. It is not OS related. True, it happens mostly on Mac. I just started to test the new SVC, developed by a different team from a different source. Will post if it happens with this one as well.


 

Looks like your connection to H7 was lost, please wait while we try to reconnect.