Package looks great, some minor install issues



  • Ok first ;)

    Seems there is no SQL data in the download package ( db settings done but no tables created, not like rvc )

    Only getting Error #2032
    Package looks great and clean great code so far



  • Please execute these statements on your MySQL database:

    CREATE TABLE IF NOT EXISTS `registrations` (
      `username` varchar(255) NOT NULL,
      `id` varchar(255) default NULL,
      `updatetime` datetime default NULL,
      `partner` varchar(255) default NULL,
      PRIMARY KEY  (`username`),
      KEY `idx_updatetime` (`updatetime`)
    ) ENGINE=InnoDB DEFAULT CHARSET=utf8;
    
    

    or download the attached file (svc_videochat-sr.X.X.sql.zip) uncompress it and import via phpMyAdmin



  • Thanks created the table Although I still have exact same error.
    I don't have to enter stratus / red5 ( not supported?) because its a p2p video chat?
    If you search flex error #2303 you come out at cross domain.xml but have that in place.
    Is there something else missing that needs to get done to make it work?



  • Please PM your FTP details and site URL.



  • @'JabberCam':

    Please PM your FTP details and site URL.

    PM'ed



  • Any idea what is causing the error?
    Perhaps the package needs to be checked again, since the SQL stuff wasn't in there it could be there
    is some more things missing in it.



  • Got your message, it's 10:17 PM. I might look at it right now or tomorrow morning (US time).



  • After debugging it a bit more
    Its looking for a .SWF called
    osmf_1.0.0.16316.swf wich cannot be found

    No idea what this is, the file is not included, this could might be the problem


    BTW: The SVC demo
    http://demo.videosoftware.pro/svc/
    included very different files and no open source media framework swf!
    Please send me a working zip with all the needed content that is correct and has everything In it to just plug and play the SVC chat,
    the current one I downloaded after payment is not working



  • ../svc/services/registration.php works and gives no SQL error, meaning the configuration is OK. Did you import the SQL to the database?

    If you generate a new release, you will have all the files you mentioned but it doesn't make any difference, these files are not needed to run SVC.The above-mentioned demo uses exactly the same package and with SVC, there are no file-rights issue or similar possibilities. It should work "right out of the box". Please send (PM) me cPanel details or at least FTP so I can take a closer look.


    I've sent you an .XML file to test the connection. Please include the content of the file to the path requested in the message (replace content of /svc/config/config.xml with the one I sent you) and fire up SVC. Let me know when the change is made.



  • Changes are made with the XML
    Though still the same error.
    the SQL was imported and DB table is available in the DB.
    It is looking for a osmf_1.0.0.16316.swf

    **
    If I copy the videochat.swf file from your SVC demo and upload it to my own server
    then do domain.com/videochat.swf I do See the video chat and see myself, IF i change the .xml to the one you provided I can even connect to other users.

    http://demo.videosoftware.pro/svc/index.php that php file is not included in my downloaded zip after purchase ( the index.php with php login )
    Also the video chat.swf on your demo site is smaller than mine, so there is definitely a difference in it! It can't be same package as installed on the video software.pro site
    **



  • The XML file I sent you connects your SVC to our public server; if using that XML-config you were able to log-in and connect to other users, means that your SVC installation is doing the following:

    • SVC loads correctly and reads from the correct location
    • data from config.xml is loaded to SVC
    • config.php and the web service is OK (I've tested your config.php and web-service)

    There are only two possible places left, where you can locate the problem:

    • the config.xml (looks fine to me)
    • the compiled VideoChat.swf <- this has to be the one

    Please set everything to its original state as you were using it first: config.php leave it as is and set the config.xml to point to your own files.
    After you're done, use the VideoChat.swf file I am sending you.



  • Follow the instructions above and use the VideoChat.swf attached below. If it connects you and works, please get back, guess I know where the problem comes from.



  • Thanks,

    I placed

    <config><language>en_US</language>
    <serviceurl>http://demo.videosoftware.pro/…/services/registration.php</serviceurl>
    <configurl>http://demo.videosoftware.pro/.../services/configuration.php</configurl></config>

    And uploaded your .SWF

    This is still not working but I can see myself but no connection, I post you URL in private message.

    I thought SVC was p2p, how would I get it up and running if a server part is required? ( Do you refer just to the database when you call it "server"? or is there more running then just the db to make it work ?)



  • Downloaded the file above and set the config.xml (the rest is not needed since the config will use our database); the chat loads, connects and works just fine. We cannot figure out the problem without FTP acces and on-site testing or it would take days of your and our time. Please allow FTP, so we can take a look, what is happening. Btw. you did everything right, settings are correct. It must have some permission issues.

    (There were similar problems with RVC and RVCS but this script is different, it runs without local web service or php support if using the given xml configuration. PHP scripts or miss-configuration cannot cause any problems, not even the SQL database. A well projected SWF application that needs a config XML only and runs/connects -right out of the box. This is one of the greatest things about SVC, it runs even if you download it to you Mac/PC or FP 10.1 enabled smartphone, does not need local web service, no php, no database -if you set the XML and connect to our remote web-service)

    SVC is p2p, this is just our database, reserved for testing purposes.



  • It is a permission issue, read this post: http://www.videosoftware.pro/forum/THREAD-Error-2032


 

Looks like your connection to H7 was lost, please wait while we try to reconnect.