Error #2032

  • After uploading the SVC-SR package to your web-server ( and loading your website, you may get the following error message:

    Error #2032

    Possible causes of error 2032:

    • the HTTPService call is unable to find the URL or the URL is blocked - If the URL is blocked or HTTPService call is unable to locate it the error will be produced.
    • the SWF is attempting to access a file on another/restricted domain - The permissions on a domain that you are trying to access in this instance may not be granting the appropriate permissions to the SWF.

    The most probable cause, in this case:

    • the VideoChat .swf cannot access the config.xml


    • check if you have the /svc/config folder and the config files on your server
    • check if config.xml has at least 644 rights
    • update SVC

  • A little more detailed, step-by-step troubleshooting (with original SVC package):
    1. uploaded contents of VideoChat.swf to your web server, loaded the page and got the #2032 error
    1.1 update VideoChat.swf to the latest version, this should solve the problem

    2. after update, you're getting "Not connected" message
    2.1 create your database and edit /svc/config/config.php, this should make SVC connect

    3. "Connected as Unknown" and "No available partner found. Waiting…"
    3.1 first message is not an error, you are not using any kind of login before loading SVC
    3.2 create the database tables by importing svc.sql

  • Appreciate the time to fix this error but this is still not working

    Followed your exact steps,

    *downloaded the purchased .zip newly from server

    • Uploaded stock files

    • Uploaded the new .SWF

    • All SVC files permission 777

    • Started clean browser session && grabbed a complete other computer that I never opened SVC on to be sure. Load page:

    Not getting a "not connected" message, only broken interface

    • No connection
    • Next button has no text on it
    • Can type text but not send it
    • Own video window Does work
    • Changed the config.xml and made the registration table based on the .SQL file
      No changes in behavior

    You can check on the same URL as posted in PM.

    *Edit: I hoped maybe somehow the language files where not loaded ( they are bundled in the .SWF? Since in the source purchased package there is no locale folder )
    Opened the video chat in 2 different computers with latest flash, hoping it would connect if I would click the Next button ( without the text) but sadly this is not the case,

  • Im still unable to get this to work
    now after 2 hours more debugging I got it working locally!!
    It seems it won't eat the stupid config.xml somehow This is my firebug error reporting:

    [RPC Fault faultString="HTTP request error" faultCode="Server.Error.Request" faultDetail="Error: [IOErrorEvent type="ioError" bubbles=false cancelable=false eventPhase=2 text="Error #2032: Stream Error. URL:"]. URL:"]
    at mx.rpc::AbstractInvoker/
    at mx.rpc::Responder/fault()
    at mx.rpc::AsyncRequest/fault()
    at DirectHTTPMessageResponder/errorHandler()

  • If there is no text on the buttons, the language resources are not loaded. This means, the config.xml is not loaded at all. The .SWF file attached above is looking for a config.xml in /svc/config folder, you won't get any further until you don't see the texts on the buttons, when you see the text, the rest will be easy.

    Just to make sure, I've tried the above file on two local machines and two different servers, the file is OK.

    Steps you can try:
    1. rename /svc folder (the chat should not load/blank screen)
    2. change the folder name back to /svc (chat will load) than rename the /config folder (no text on buttons)
    3. when changing back the name to /config, texts should load
    4. if texts are loaded, try changing the path in config.xml (../../svc/services) to absolute path
    5. try on a different server, you may loose your time due to a server-configuration that you are not aware of

  • Im Using Nginx and I believe there lies part of the problem,
    Since locally it runs just fine, haven't been able to debug this but for now Il consider this a problem on my side of the track.
    The script is great and seems to work fine in localhost.

    I keep posted here, going to try apache as server see if same happens.
    And Ill be upgrading my Nginx soon hope that solves the problem.
    I post back when I know more! thx!

  • Hi
    i recently purchased svs. The swf file that i got along with the download is not working and it shows 2032 error. I have downloaded the swf file here and it works fine. What should i do to get the original swf working? I like that layout and it doesnt contain your link also.
    Please advice

  • There will be a hot-fix released in a short time, I would say tomorrow but cannot confirm it. This release will contain the fix for the HTTPService issues (defaults removed), together with fixes for some skin-related bugs that caused high memory usage and FP crash.

    The next release (probably 0.8) will include support for sending custom data over RTMFP, for implementing the drawing feature, added about a week ago:

  • If you are designing custom layouts for SVC, don't hesitate to continue your work, the core updates won't affect the skins or layouts. More than likely, there will be a new library to replace 0.7 and maybe some new components (not sure about this second one).

  • But I need the source code of a working swf. The one I downloaded during purchase wont be working as the swf is not. Please send me source code of a working swf. ALos can i get the update for free? as I have upgraded to svc yesterday only

  • I am not sure about updates, probably everyone will get the first ones for free. This one for sure.

  • wasn't able to load the chat (your site did not respond), try downloading the free version and test with it:


    You don't have permission to access / on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/2 Server at Port 80

    I am sorry but I don't understand the second question …

Log in to reply