Audio still playing after mp3 files have been deleted



  • Hi,

    I have successfully install RVC and its working fine, but i have deleted the mp3 files from the "sounds" folder and i have clear the browser too, but the audio is still playing.

    Please help me with this problem.

    Thanks,
    Esmond.



  • it is the browser cache, hold Shift and reload the page or clear your browser's cache



  • Hi,

    I hold the shift key and refresh the browser several times and i have also clear the browsers cache, i have been doing this since yesterday, All the audio files have been deleted from the server. but the audio still plays.

    Site URL: http://www.space.com.gh/chatroulette/

    Thanks,
    Esmond.



  • I took a look and it is strange(?!), the sounds are loaded from somewhere…

    There are two things that come to my mind, first, the swf is loaded from somewhere else and uses different WEB_SERVICE_URL or the correct swf is loaded but wrong WEB_SERVICE_URL is used. Please post here the relevant section of your config.php:

    /**
     * Configuration file for RVC 5.0+
     * You may want to edit /jabbercam/language/lang_??.ini
     * Help: http://www.videosoftware.pro/forum/FORUM-Documentation-Quickstart-and-How-To
     */
    
    //SYSTEM SETTINGS
    
    /* Back-en location (exact location of functions.php on your domain | http://www.your_domain.com/[folder]/jabbercam/functions.php */
    $WEB_SERVICE_URL = "http://www.WEB_SERVICE_URL/jabbercam/functions.php";                // http://www.your_domain.com/jabbercam/functions.php
    $GOOGLE_APP_ID = "GOOGLE_MAPS_APP_ID";                                                                      // required for Google maps (to remove, read forum)
    ...
    
    


  • //SYSTEM SETTINGS

    /* Back-en location (exact location of functions.php on your domain | http://www.your_domain.com/[folder]/jabbercam/functions.php */
    $WEB_SERVICE_URL = "http://www.space.com.gh/chatroulette/jabbercam/functions.php"; // http://www.your_domain.com/jabbercam/functions.php
    $GOOGLE_APP_ID = "ABQIAAAAcETCg3cfDeRGebzkR93W8RQ2pXOYVdMy0gt-g8q_wvqY-WP94RSWvhXT-VLxZrUVGx-dDuejNVXazw"; // required for Google maps (to remove, read forum)



  • pass …

    the sounds are not hard-coded, the soft is loading them from somewhere, try removing the .htaccess file and use www when calling the URL



  • No idea, the sounds are loaded from the media dir and your soft is loading them from somewhere else.
    It may be a redirection somewhere ~



  • Hi,

    Checking from the index.html i found this, Can it be the problem ?

    <object id="JabberCam" width="666" height="488"><param name="movie" value="JabberCam.swf" codebase="http://fpdownload.macromedia.com/get/flashplayer/current/swflash.cab">
    <param name="quality" value="high">
    <param name="bgcolor" value="#FFFFFF">
    <param name="scale" value="noscale">
    <param name="allowFullScreen" value="true">
    <param name="allowscriptaccess" value="always">
    <param name="base" value="http://demo.videosoftware.pro/rvc/">
    <param name="wmode" value="transparent">
    <embed name="JabberCam" src="JabberCam.swf" loop="false" quality="high" play="true" bgcolor="#FFFFFF" width="666" height="488" align="middle" scale="noscale" wmode="transparent" type="application/x-shockwave-flash" pluginspage="http://www.adobe.com/go/getflashplayer" <strong="">base="http://demo.videosoftware.pro/rvc/" allowscriptaccess="always" allowfullscreen="true"></object>

    Thanks,
    Esmond.



  • yes, somehow this is the original file… change the values to your own domain/folder



  • Hi,

    Now the sound problem is OK. I contact my friends in different countries to log onto my website and NONE of them was able to connect with me or able to connect with other friends and we were all online at the same time. When i open two browsers on the same PC it works fine. but not in different locations. What can cause this problem?.

    When you say: "deploy the applet (/Red5_serverapp/deploy_app/ChatrouletteApp) to your webapp folder" can you explain further, this is the last part for me to start running on Red5.

    My site URL: http://www.space.com.gh/chatroulette/

    Thanks,
    Esmond.



  • The first problem is strange … will test it. The second is an optional, media server alternative, you don't need it in this case.



  • Hi,

    Can firewall cause this problem? I contact my hosting provider to check if firewall is active on my VPS server, and they said its active and they are requesting ports to open. Are ports associated with this software?.

    Thanks,
    Esmond.



  • Well a firewall can definitely block p2p connections but rather a local one, running on your device than one on your server. Firewall can also block ports used by Red5, but here is not the case. I don't think it is a firewall…



  • Hi,

    I will like to know what you are doing to get my software's working, All the three software's i bought RVC, RVCS and SVC, installations are successful but none is connecting to a partner in different locations, but works on same PC with two browsers and I am running out of time to launch my website.

    Please help.

    Site URLs: http://www.space.com.gh/chatroulette/ http://www.space.com.gh/chatroulette2/ http://www.space.com.gh/chatroulette3/

    Thanks,
    Esmond.



  • Hi,

    Please help.

    Thanks,
    Esmond.



  • Hello,

    The first installation works without problems,
    the second one is loading slow and "Initializing", this means, the setup process wasn't finalized. Check this post: http://www.videosoftware.pro/forum/THREAD-RVCS-versions-Upgrade?pid=1457#pid1457
    the third installation starts and connects but does not register the user, the possible cause is lack of database tables, check this post: http://www.videosoftware.pro/forum/THREAD-Package-looks-great-some-minor-install-issues



  • Hi,

    The first installation as you said it works without problems is not working for me.
    It only work with two browsers or two PCs on the same network but not in different locations.

    Please call a friend in different location to log on to http://www.space.com.gh/chatroulette/ and see if you can connect to each other.

    Thanks,
    Esmond.



  • The RVC is creating p2p connection (RTMFP), using Cirrus (or Red5 by default). Some firewalls may block this and if such, it is not a software issue, much rather a server security setting. You may try with Red5 (RTMP) since it won't use p2p connections.



  • 16:56:37  Connected! to fvkfhi from Somewhere
    16:56:37  Hit NEXT to ignore or continue chatting with this partner
    Video Call: hi

    …seems that your chat works I was connected to someone. BTW the chat loads very slow, in about one minute!



  • Hi,

    a. when you say "deploy the applet (/Red5_serverapp/deploy_app/ChatrouletteApp) to your webapp folder" what thus this mean.

    b. Please check for me if the below is correct

    <object id="JabberCam" width="666" height="488"><param name="movie" value="JabberCam.swf" codebase="http://fpdownload.macromedia.com/get/flashplayer/current/swflash.cab">
    <param name="quality" value="high">
    <param name="bgcolor" value="#3B5997">
    <param name="scale" value="noscale">
    <param name="allowFullScreen" value="true">
    <param name="allowscriptaccess" value="always">
    <param name="base" value="http://space.com.gh/chatroulette/">
    <param name="wmode" value="transparent">
    <embed name="JabberCam" src="JabberCam.swf" loop="false" quality="high" play="true" bgcolor="#3B5997" width="666" height="488" align="middle" scale="noscale" wmode="transparent" type="application/x-shockwave-flash" pluginspage="http://www.adobe.com/go/getflashplayer" base="http://space.com.gh/chatroulette/" allowscriptaccess="always" allowfullscreen="true"></object>

    Thanks,
    Esmond.


Log in to reply