Installation FAIL



  • Hi,
    I bought your software SVC-SR
    It came in the zip file
    svc_videochat-sr.0.8.141
    I follow the instruction in your forum
    I created the database and configured the database.
    I uploaded all the files including the customized files (conf.xml and config.php)
    1.The homepage shows just my video buffering and says "not connected", I guess to CIRRUS.
    2.the tables in the DB were not created
    3.There are no skins nor a folder called style from which select them.
    4.There is no speed-date feature
    Would you please help me to solve this issue?
    Thanks a lot in advance,
    Frank



  • Hey, it seems like the database tables are missing. Try to run /svc/install.php (you should have install.php and create.sql in the /svc folder). You can also import the database via phpMyAdmin from here: http://www.videosoftware.pro/forum/THREAD-Package-looks-great-some-minor-install-issues?pid=2879#pid2879

    The skins are located in the Adobe Flash Builder project. Just import the .fxp file to FB. Some instructions can be found here, these will be the same for SVC:

    http://www.videosoftware.pro/forum/THREAD-Some-basic-and-frequently-asked-editing
    http://www.videosoftware.pro/forum/THREAD-Installing-and-editing-RVC-5-PART2-step-by-step-description

    SpeedDate applies to RVC, you should have that software as well if you got the bundle.



  • Hello, I got your message:

    Hi there is no install.php, not a fxp file
    the package that I bought is
    svc_videochat-sr.0.8.141

    • if there is no install.php, just populate the database via phpMyAdmin as mentioned above
    • unzip svc_videochat-sr.0.8.141 and you will get:
    • LICENSE.pdf (the license)
    • README.txt (read this)
    • SVC.fxp (the source code - edit with Flash Builder)
    • VideoChat.zip (the compiled software - this is the actual software that goes to your server)


  • Thank you for your help,
    Looks like the antispam banned me so I am using this user.
    I found the fxp file.
    I populate the DB by creating the table "registration" with the sql code you suggest.
    The website still not working…....



  • I have experience in installing LAMP script or similar,
    I created the table "registration" with the sql code you suggested.
    Still the website doesn't work. I already waited 2 weeks since bought the script.
    Money back?



  • What is your URL?



  • Hey thanks Govido,
    I sent you a pm with the link.
    I mean it's a quite easy installation.
    1. create the table in the db through the sql code
    2. upload the files
    3. configure the file "config.php" with the db setting
    4. configure the "config.xml" with the exact url for configuration.php and registration.php, which in this package are located inside the folder ../services/
    Maybe somethikng wrong with the package version?



  • Hey, please read trough the comments of this post, Sharkman has similar problem. Just created a fresh installation on a cPanel server for testing: http://www.videosoftware.pro/forum/THREAD-Installing-and-configuring-SVC-SR-video-chat



  • svc_videochat-sr.0.8.141 was used as downloaded from the sales interface



  • …/svc/services/configuration.php seems OK
    .../svc/services/registration.php seems OK

    • meaning config.php (database access) is configured properly

    Possible issues left:
    1. database tables missing/not properly created - drop all tables and use the installer script: http://www.videosoftware.pro/forum/THREAD-Installing-and-configuring-SVC-SR-video-chat

    2. config.xml misconfigured or not properly saved. My browser(s) load your config.xml in a different way than the original one, try using the original config.xml, see my sample (replace the XXXXXXX) and save it with a code editor (ex. Komodo, EditPlus or similar) or an online code editor (ex. cPanel's File Manager/Code Editor):

    
     <config><language>en_US</language>
    	<serviceurl>http://www.XXXXXXX.com/svc/services/registration.php</serviceurl>
    	<configurl>http://www.XXXXXXX.com/svc/services/configuration.php</configurl></config> 
    
    

    3. config.xml not accessible - there is a rare possibility that your VideoChat.swf application is not allowed to access config.xml. This is a server setting and should be addressed by your server admin. Use a different server to test if this is the case, I am able to create one, similar to Sharkman's test account.



  • Govido I read the solution to the bug that you suggested, and it seems reasonable.
    However, it implies the use of a static IP which the majority of people don't have because of its cost.
    the ip of a shared hosting is dynamic, so even configuring the config.xml with the ip will work only until the next session.
    Please, correct me if I am wrong



  • There is nothing to do with the IP address, it is just a link I posted without having a domain name. Instead of the IP address, you should use your own domain; if you read further, there is a sample with the domain videosoftware.pro



  • Hi,
    I spent the weekend trying all the changes suggested.

    1 create, re-create, and populate the db
    2 editing the original config.xml using the online editor
    3 tried to use in the url /~username/svc/services/registration.php
    4 tried to use in the url svc/services/registration.php withouth username
    5 gave executive permission to the VideoChat.swf and config.xml (7 4 4)

    Nothing changed, any clue?
    Thanks



  • This is getting frustrating and time-consuming. Send me your FTP details in a PM, I will take a look if there is anything missing or misconfigured. On the other hand if you copy all the files from the demo account I created it should work as it works on the test server. Anyway, waiting for your PM. Thanks!



  • Thanks a lot Govido,
    which demo account? Where do you create it?



  • Sorry, I confused two similar forum posts. Do you need a demo account?



  • Govido,
    I pm the ftp details,
    Thanks



  • Hello, I did install the latest package on your server and used a special config.xml for remotely connect to my own web service and database. Here is a screenshot (ranxxxx.com.png), the software works on your server.

    I did re-configure the xml file to use your own web service. As soon as you edit config.php and insert your own database details, this service should start without problem. If the SVC did connect to my web service, it means it does read from config.xml and the rest is pure PHP/MySQL.

    Don't forget to check if the database is configured properly, by accessing http://ran****.com/svc/services/registration.php and if so, please run the installer script to create your database tables: http://www.videosoftware.pro/forum/THREAD-Installing-and-configuring-SVC-SR-video-chat?pid=6260#pid6260



  • Ok, so I replaced the config.php file with mine, which includes the db connection fields.

    I ran the install.php and it did not work.
    "Query is invalid or cannot be executed: You have an error in your SQL syntax"

    I ran the sql code manually on my phpmyadmin and successfully created the two tables.

    I am sure that the fields that my config.php uses for connection to the db are right. I tested them through another script
    ../testsql.php

    STILL does not connect. Do you want me to pm you the db details?

    Thanks for your help


    Forgot to say, you can use the fields for db connections from config.php
    in the testsql.php
    As you will see the db is connected



  • No, if you still have the same FTP access, you created for me, just leave config.php as it is (configured to access your db) and I'll take a look.


Log in to reply
 

© 2108 H7 | Powered by NodeBB

Looks like your connection to H7 was lost, please wait while we try to reconnect.