Ver 0.9.178 connects to someone else's users

  • I just put the new 0.9.178 up on my test server to check it against my database that is currently in use for ver 0.8 The new version seems to be connecting to users that are on someone else's database because they are not in mine.

    How is this possible? I have even taken just the VideoChat.swf and placed it into a known working website and it still connects to users that are not on that site.

    What's going on with this?


  • The latest SVC is able to connect to any public web service (if found). To turn off this option completely, edit config.xml and replace the "remote" property with "local".

  • Yes, I read that elsewhere here on your forum… I made that change and it still connected to someones "public" web service. Also as I stated in my post, I took the new .swf and placed it into a known working site (using a config.xml that was already in place and does not even have the "webservice" tag)


  • Versions after 0.8 are using slightly different configuration. It is possible to connect to older databases via a newer software (backward compatible) but you'll need the new config.xml. If a different (older) config is found, the SVC is looking for remote web-services.
    If you are using the latest soft and latest .xml, it will connect to your local database with the "local" setting, don't forget to clear the browser's cache and reload the soft.

  • Using the NEW .swf and the NEW config.xml –
    With setting on REMOTE - it connects to remote database.
    With setting on LOCAL - it does nothing. It just shows the "Arrow" where it should show "Connected as..."

    The old .swf with the old config.xml connects to my database just fine. I copied the same settings over to the new config.xml - the connection settings are correct.

    Please tell me where the SVC is coded to look for remote web services... where is the address of the web services hard coded into the application? I have scoured the .fxp (.zip) and cannot see anywhere that an address is hard coded.

  • Spollock, replace the whole /services and /config folder yo use the latest SVC, there are new files and several changes including some variables that are necessary to create a successful connection.

  • I did that… simply says "Not connected"

  • Please try a complete new install with the files provided in the package, it should work… if it does not, I'll ask for help.

  • I think I have it figured out. May have been an issue with subdomain and location of new /services/files

    will report back with my findings.


Log in to reply